Why does the Tobii Dynavox PCEye Explore require USB 3.0?

The Tobii Dynavox PCEye Explore requires a USB 3.0 connection as only USB 3.0 provides it with sufficient power and signal bandwidth. Due to the required amount of bandwidth and power, the Tobii Dynavox PCEye Explore is not downwards compatible to USB 2.0 like e.g. USB 3.0 memory sticks or external hard drives are. This means that if your USB 3.0 controller is not USB 3.0 certified, you might run into problems with an unsuccessful connection. An error message will inform you about the next steps.

© Copyright 2019 Tobii Dynavox

Terms & ConditionsLegal NoticePrivacy PolicyHIPAA Policy